Oberon Community Platform Forum

Development => UnixAOS => Topic started by: staubesv on August 19, 2008, 09:37:49 AM



Title: DarwinAos - libX11.6.dylib version
Post by: staubesv on August 19, 2008, 09:37:49 AM
Dear Guenther,

A OCP member wrote in an e-mail:

Quote
UnixAos runs fine on Leopard. Unfortunately, UnixAos 0.80 for Darwin 
won't start on MacOS X 10.4.11 because it requires libX11.6.dylib 
version 9.0.0 or later and Tiger provides version 6.2.0.

Is the new version of libX11.6.dylib strictly required?



Title: Re: DarwinAos - libX11.6.dylib version
Post by: gfeldm on August 19, 2008, 04:21:40 PM
No, there is no special version of libX11 needed. The demand for version 9 results from creating
the boot loader 'aos.darwin' under Leopard (I have no MacOS Tiger at hand). To create a boot loader
for MacOS Tiger do the following (on a MacOS Tiger system):

        cd  <aosrep>/UnixAos/boot
        make -f Makefile.darwin
        cp  aos.darwin  <aos install dir>


-- Guenter


Title: Re: DarwinAos - libX11.6.dylib version
Post by: wn on September 28, 2008, 11:39:03 AM
This solution works fine, UnixAos is now running on Mac OS X Tiger too.
Thank you.

Wim Niemann


Title: Re: DarwinAos - libX11.6.dylib version
Post by: LonnieEilerman on February 21, 2011, 01:44:08 AM
I am using snow leopard.

magic of making up (http://honestreview4u.com/magic-of-making-up) | reverse phone detective (http://honestreview4u.com/reverse-phone-detective)