Oberon Community Platform Forum
November 22, 2019, 06:03:42 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: traps in SkinEngine  (Read 2894 times)
fnecati
Jr. Member
**
Posts: 60


« on: May 06, 2011, 02:58:48 PM »


When stijin, stijinbw, Christmas, OSX skins are selected from Menu-Looks-SkinLoader a few times
the following checksum errors etc. written to linux terminal and sometimes to the red Trap window.


I had sent this problem to bugtracker as issue ID = 050.

I forgot to mention there that my system is Ubuntu 10.04, X64, PC: Intel Q6600, Core2Quad.
Traps does not occur in 32bit linux, Pardus, system but on my ubuntu x64 system.

Can any body confirm this ?

Red-Trap window indicates some hints, may be in PNGDecoder module or in the png pictures itself?

Attached file is for a few trial result,  linux teminal log and Oberon red trap window.



UnixAos 0.96

In Linux terminal:
************************************************************
1. run
************************************************************
Kernel: Initialized and started.
X11 Display depth = 24
Default font installedOpenType 0.45 BBPort /3.12.2004  eos, pl
WindowManager: 16-bit color
WindowManager: Display resolution: 1424x820x24
DisplayRefresher installed.
Autostart: executing WMTrapWriter.Install
{P cpuid= 0, pid= -384390288 Events: System event log started.}
WMMacros: Macro file Macros.XML loaded.
Autostart: executing UpTime.Install
Uptime monitor started.
Autostart: executing StartMenu.Open
Autostart: executing SkinEngine.Unload
ZeroSkin already loaded
Autostart: executing WMRestorable.Load Auto.dsk
{P cpuid= 0, pid= -384390288 Starting logger}
WMRestorable: Loading desktop from Auto.dsk...
Autostart: executing WMNavigate.Open -vs 1 0 0 Navigation:TaskList
SyntaxHighlighter: Auto-loading SyntaxHighlighter.XML ... done.
tion>Shutdown</Caption>
         <Alignment>2</Alignment>
         <ClDefault>0FF000080</ClDefault>
         <OnClickH  checksum error
�� ��4����k/������q'ۺ�i�3�=骕�,I�Ô����f�Hkg���8��o縱An7�5������l��Q��>�>���ɻ�F�){�F=��Sz�  checksum error
extHover>0BF0000FF</ClTextHover>
         <UseBgBitmaps>TRUE</UseBgBitmaps>
         <BgMiddleDefault>stijn.skin  checksum error
SkinEngine : Loading stijn.skin...ok
loading stijn.skin://startmenu/layout0.XML
Cleanup
{P cpuid= 0, pid= -468317328 Events: System event log shut down.}
WindowManager: Window manager closed
Objects 3029 discarded finalizers, 0 pending finalizers
Oberon.Files 9 discarded finalizers, 0 pending finalizers

* MySkinLoaderTraps.txt (10.04 KB - downloaded 361 times.)
Logged
gfeldm
Moderator
Newbie
*****
Posts: 29


« Reply #1 on: May 06, 2011, 03:47:28 PM »


I get similar checksum errors in the Darwin port as well but never in the
Solaris port. Huh. All ports use the same compiler and I could not find
any differences in the *.skin files.

-- Guenter
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!