Oberon Community Platform Forum
November 19, 2019, 07:04:48 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News:
 
   Home   Help Search Login Register  
Pages: 1 [2]
  Print  
Author Topic: Black screen at boot  (Read 25291 times)
staubesv
Administrator
Sr. Member
*****
Posts: 387



« Reply #15 on: March 27, 2008, 09:10:43 AM »

The blank blue screen means that the window manager started. The graphical installer enables automatic hardware detection as default. Try to set the config string HardwareDetection=0 to disable it (only the legacy drivers, i.e. PS/2 Mouse and Keyboard will be loaded then).

Remark: If you set Init=, the system will not switch to graphics mode, i.e. it won't boot. This is only useful in combination with TraceMode=1 (trace output on screen in text mode).
Logged
leledumbo
Jr. Member
**
Posts: 96



WWW
« Reply #16 on: March 28, 2008, 08:56:47 AM »

Update: AOS boots OK with MaxProcs=-1, don't know how

Here's the result when tracing again (without MaxProcs=-1):
Quote
Commands.Runner.@Body pc=671 [0000029FH]
@Self=00799C90H
{P cpuid= 1, pid= -1
Exception during command execution.
Default font installedOpenType 0.45 BBPort /3.12.2004 eos, pl
It's annoying to know that I have to set MaxProcs=-1 EVERYTIME I want AOS to boot.
Logged
staubesv
Administrator
Sr. Member
*****
Posts: 387



« Reply #17 on: March 28, 2008, 09:09:58 AM »

You don't have to! After entering MaxProcs=-1 in the boot loader's prompt, just press 'w' followed by 'return' to make the change persistent. Then continue the boot process by pressing 'c' followed by 'return'.

Since USB seems to cause problems on your machine, it would be nice to know what USB host controllers you have. Could you please attach the output of the command AosPCITools.Scan ~? Also, does the USB flash drive when attaching it after AOS has booted?
Logged
leledumbo
Jr. Member
**
Posts: 96



WWW
« Reply #18 on: April 03, 2008, 03:06:05 AM »

Sorry for the long reply, I was upgrading to the latest crazy fresh release. Here's the output of PCITools.Scan ~:
Quote
PCI bus enumeration:

Bus 0, device 0, function 0: class/rev 06000000, vendor/device 10390671, status/cmd 22000107

   Class: Bridge, Sub-class: Host bridge

   Vendor: Silicon Integrated Systems [SiS], Device: 671MX

   Driver: n/a

      IRQ255



Bus 0, device 1, function 0: class/rev 06040000, vendor/device 10390004, status/cmd 00100407

   Class: Bridge, Sub-class: PCI bridge, ProgIntfc: Normal decode

   Vendor: Silicon Integrated Systems [SiS], Device: PCI-to-PCI bridge

   Driver: n/a



Bus 1, device 0, function 0: class/rev 030000A1, vendor/device 10DE01D3, status/cmd 00100107

   Class: Display controller, Sub-class: VGA compatible controller, ProgIntfc: VGA controller

   Vendor: nVidia Corporation, Device: G72 [GeForce 7300 SE]

   Driver: n/a

      IRQ10, INTA

      16MB 32-bit memory at FD000000-FDFFFFFF

      256MB prefetchable 64-bit memory at D0000000-DFFFFFFF

      16MB 64-bit memory at FC000000-FCFFFFFF

      ROM atFEBE0000



Bus 0, device 2, function 0: class/rev 06010001, vendor/device 10390968, status/cmd 0200000F

   Class: Bridge, Sub-class: ISA bridge

   Vendor: Silicon Integrated Systems [SiS], Device: SiS968 [MuTIOL Media IO]

   Driver: n/a



Bus 0, device 2, function 5: class/rev 01018001, vendor/device 10395513, status/cmd 02100005

   Class: Mass storage controller, Sub-class: IDE interface

   Vendor: Silicon Integrated Systems [SiS], Device: 5513 [IDE]

   Driver: AosATADisks.Install

      0GB I/O at 00000000-FFFFFFFF

      0GB I/O at 00000000-FFFFFFFF

      0GB I/O at 00000000-FFFFFFFF

      0GB I/O at 00000000-FFFFFFFF

      16B I/O at 0000FFE0-0000FFEF



Bus 0, device 3, function 0: class/rev 0C03100F, vendor/device 10397001, status/cmd 62800117

   Class: Serial bus controller, Sub-class: USB Controller, ProgIntfc: OHCI

   Vendor: Silicon Integrated Systems [SiS], Device: USB 1.0 Controller

   Driver: AosUsbHubDriver.Install;AosUsbOhci.Install

      IRQ11, INTA

      4KB 32-bit memory at FBFFF000-FBFFFFFF



Bus 0, device 3, function 1: class/rev 0C03100F, vendor/device 10397001, status/cmd 62800117

   Class: Serial bus controller, Sub-class: USB Controller, ProgIntfc: OHCI

   Vendor: Silicon Integrated Systems [SiS], Device: USB 1.0 Controller

   Driver: AosUsbHubDriver.Install;AosUsbOhci.Install

      IRQ5, INTB

      4KB 32-bit memory at FBFFE000-FBFFEFFF



Bus 0, device 3, function 3: class/rev 0C032000, vendor/device 10397002, status/cmd 02900106

   Class: Serial bus controller, Sub-class: USB Controller, ProgIntfc: EHCI

   Vendor: Silicon Integrated Systems [SiS], Device: USB 2.0 Controller

   Driver: AosUsbHubDriver.Install;AosUsbEhci.Install

      IRQ15, INTC

      4KB 32-bit memory at FBFFD000-FBFFDFFF



Bus 0, device 4, function 0: class/rev 02000002, vendor/device 10390191, status/cmd 02100007

   Class: Network controller, Sub-class: Ethernet controller

   Vendor: Silicon Integrated Systems [SiS], Device: 191 Gigabit Ethernet Adapter

   Driver: n/a

      IRQ3, INTA

      128B 32-bit memory at FBFFCC00-FBFFCC7F

      128B I/O at 0000EC00-0000EC7F



Bus 0, device 5, function 0: class/rev 01018503, vendor/device 10391183, status/cmd 02100005

   Class: Mass storage controller, Sub-class: IDE interface

   Vendor: Silicon Integrated Systems [SiS], Device: SATA Controller / IDE mode

   Driver: AosATADisks.Install

      IRQ10, INTA

      8B I/O at 0000E800-0000E807

      4B I/O at 0000E400-0000E403

      8B I/O at 0000E000-0000E007

      4B I/O at 0000DC00-0000DC03

      16B I/O at 0000D800-0000D80F

      128B I/O at 0000D400-0000D47F



Bus 0, device 6, function 0: class/rev 06040000, vendor/device 1039000A, status/cmd 00100104

   Class: Bridge, Sub-class: PCI bridge, ProgIntfc: Normal decode

   Vendor: Silicon Integrated Systems [SiS], Device: PCI-to-PCI bridge

   Driver: n/a



Bus 0, device 7, function 0: class/rev 06040000, vendor/device 1039000A, status/cmd 00100104

   Class: Bridge, Sub-class: PCI bridge, ProgIntfc: Normal decode

   Vendor: Silicon Integrated Systems [SiS], Device: PCI-to-PCI bridge

   Driver: n/a



Bus 0, device 15, function 0: class/rev 04030000, vendor/device 10397502, status/cmd 02100006

   Class: Multimedia controller, Sub-class: Audio device

   Vendor: Silicon Integrated Systems [SiS], Device: Azalia Audio Controller

   Driver: n/a

      IRQ11, INTA

      16KB 32-bit memory at FBFF4000-FBFF7FFF



13 devices found
In the latest release, I found that my dual processor & USB problem aren't yet fixed. But from the trace output, the window manager starts even without MaxProcs=-1. No exception occurs, but AOS still won't boot.
Logged
Pages: 1 [2]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!